Welcome
!
How can we help?

Compatibility

In order to connect your Orbit to the Me app you will need a compatible smartphone.

It works with iPhone 4s or newer and Bluetooth Smart Ready Android devices running Android 4.3 or higher.

Submit request